Support


Reminder: Please ensure that your unit is running the latest software.

Search Support Center:
 Why do I get error "The product identifier of the unit eXplorist is not compatible with this upgrade?"
Article This error will appear if your eXplorist GC has a software version lower than 1.7(PC) or 1.8(Mac) and will need to be updated to this version prior to updating to the latest software version 2.15. Follow the steps below to determine if your eXplorist GC has Software lower than version 1.7(PC) or 1.8(Mac):
  1. From the map screen press back key and select “Tools” (screwdriver and wrench icon)
  2. Select “Settings” and press enter
  3. Next scroll down and select “Product Info” and press enter
  4. A screen with the SW version and serial number will appear if you have a version lower than 1.7(PC) or 1.8(Mac) click on the link below to update your eXplorist GC to version 1.7(PC) or 1.8(Mac)

    For PC Users:
    http://d1yle3idvjeby9.cloudfront.net/eXplorist_GC_1_7_Rel2.exe

    For Mac Users:
    http://d1yle3idvjeby9.cloudfront.net/eXploristGC_1.8.1349.777_Web_Mac/Mac_eXploristGC_1_8.dmg

  5. Once you have completed this update go back to the software update page below to update your eXplorist GC to version 2.15
    http://support.magellangps.com/support/index.php?_m=downloads&_a=view&parentcategoryid=62&pcid=24&nav=0,18,24


Article Details
Total Views:5900
Created On: 31 Oct 2013 5:45 PM

 This article was helpful  This article was not helpful

 Back
Kayako Skin by SupportSkins.com